use strict;
my $str = 'Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept
object/custom/name1/name2
object/custom/name1/name2/typea
object/custom/name1/name2/typea/item
object/standard/name1/name2
object/standard/name1/name2/typeb
object/standard/name1/name2/typeb/item';
my $regex = qr/object\/(custom|standard)\/(.*)(?:\/(typea|typeb))(?:\/(.*))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}