$re = '/^([a-zA-Z]+) is \1$/m';
$str = 'anna is ann
anna is anna
anna is anna
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);