import re
regex = re.compile(r"/pt-br/aeroportos/(?!brasil)|/pt-br/localidades/(?!brasil)|/pt-br/locadora/[^/]+/((?!brasil).)+$")
test_str = ("/pt-br/aeroportos/estados-unidos/mco-orlando-florida\n"
"/pt-br/\n"
"/pt-br/alugar/estados-unidos/miami-florida\n"
"/pt-br/aeroportos/estados-unidos/fll-fort-lauderdale-hollywood-fort-lauderdale-florida\n"
"/pt-br/localidades/estados-unidos/miami-florida\n"
"/pt-br/carros/estados-unidos/miami-florida\n"
"/pt-br/localidades/brasil/rio-de-janeiro-rio-de-janeiro\n"
"/pt-br/localidades/brasil/sao-paulo-sao-paulo\n"
"/pt-br/aeroportos/brasil/fln-hercilio-luz-florianopolis-santa-catarina\n"
"/pt-br/locadora/localiza/brasil/campinas-sao-paulo\n"
"/pt-br/locadora/localiza\n"
"/pt-br/locadora/localiza/brasil\n"
"/pt-br/locadora/localiza/estaasdasd/bananas")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")