$re = '/.*?\bcar\b(?!.{0,10}\bnot\b).*/m';
$str = 'This car is not that fast!
The car you are about to see may not be that fast, but it\'s very beautiful!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);