Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?P<number>\d+) (?P<word>\w+)
"
gm
Input 1
1
New
ABC 123 Book 456 ZZZ 789 KKK XYZ
Substitution
\g<word> \g<number>
ABC 123 Book 456 ZZZ 789 KKK XYZ