#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]{2,}(?!.*(?:FO|SH|GDP|LDP).*).*$"
Local $sString = "12(3)/FO.2-3;1-2" & @CRLF & _
"153/G6S.3-H;2-3;1-2" & @CRLF & _
"1/G13S.2-3" & @CRLF & _
"22/FO.2-3;1-2" & @CRLF & _
"12(3)2S/FO.2-3;1-2" & @CRLF & _
"153/SH/G6S.3-H;2-3;1-2" & @CRLF & _
"45/3/H/GDP6;2-3;1-2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")