const regex = /(<a[^>]*)>([^<]*)(<\/a>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a[^>]*)>([^<]*)(<\\\/a>)', 'g')
const str = `<ul>
<li><a href="www.google.com" target="blank">Google</a></li>
<li><a href="www.yahoo.com" target="blank">Yahoo</a></li>
<li><a href="www.bing.com" target="blank">Bing</a></li>
</ul>`;
const subst = `$1 aria-label="$2">$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);