# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\Qhttps:\/\/\E(?:[^\\/:]+\.)?gstatic\.(?:net|com)((?!recaptcha).)*$/$/gm;t' <<< "https://www1.www2.www3.gstatic.net/aaaaaarecaptchassssssss"