#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+\s+[0-9]+\s+2\s"
Local $sString = "134 1 2 6 3.45388e-06" & @CRLF & _
"135 1 2 7 3.04626e-06" & @CRLF & _
"136 1 2 8 4.69364e-06" & @CRLF & _
"137 1 3 9 4.21627e-06" & @CRLF & _
"138 1 3 10 2.38822e-06" & @CRLF & _
"139 1 2 11 1.91216e-06"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")