re = /^([^\t\r\n]*)\t([^\t\r\n]*)\t([^\t\r\n]*)$/m
str = 'AFRIKAANS South Africa ca
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end