using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Za-z-]+\d|[\d-]+[A-Za-z])[\w-]*\s*";
string substitution = @"";
string input = @"2fvRE-Ku89lkRVJ44QQFN ABACUS LABS, INC
abc123 CAT LABS, INC";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}