re = /^((?:[A-Z0-9]+_?)+)(?<!_)=(?=(.*))|(<[^\/].*?>)|(<\/.*?>)|({\w*}%?)/m
str = 'STR_ABL_DAMUP_WIND_EXPLAIN=<Picture id="ICN_PRM_007"/>Wind attack power +{Perc}%
STR_ARENA_ENTRY_INFOMATION_PAGE_05=<__>The first time you clear the challenge, you will receive a<__><Color id="Yellow">reward</Color>, so give it your all!
STR_CHAT_VIEWER_TRADE_SPIRITS=You can unlock this chat for {TradeRate} katz spirits.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end