# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[abc\].*)(kuku)(.*\[\\/abc\])/\1\\\2\3/gm;t' <<< "[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]"