re = /(\[abc\].*)(kuku)(.*\[\/abc\])/m
str = '[abc]kuku na bruku i duzo huku[/abc] kuku [abc] kuku [/abc]'
subst = '\\1\\\\\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result