#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{5}$)[a-z]*\d[a-z]*$"
Local $sString = "jlwk6" & @CRLF & _
"bjkgp" & @CRLF & _
"5fm8s" & @CRLF & _
"x975t" & @CRLF & _
"k88q5" & @CRLF & _
"zl796" & @CRLF & _
"qm9hb" & @CRLF & _
"h6gtf" & @CRLF & _
"9rm9p" & @CRLF & _
"jwzw2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")