const regex = /(?:^\K.*+\R?){6}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\K.*+\\R?){6}', 'gm')
const str = `Question text
A. Answer Option
B. Answer Option
C. Answer Option
D. Answer Option
Explanation text
Question text
E. Answer Option
F. Answer Option
G. Answer Option
H. Answer Option
Explanation text
Question text
I. Answer Option
J. Answer Option
K. Answer Option
L. Answer Option
Explanation text
Question text
M. Answer Option`;
const subst = `Explanation\n$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);