package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^url\(.+\)$`)
var str = `url(https://picsum.photos/99/148?grayscale)
url('https://picsum.photos/99/148?grayscale')
url("https://picsum.photos/99/148?grayscale")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}