const regex = />([^*]*?)(<br|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>([^*]*?)(<br|$)', 'gm')
const str = `>Some quote <br />
Some simple text<br />
<br>
> another quote with random <b>tags</b> and <a href=>links</a> in it`;
const subst = `<mark class=\'quote\'>$1</mark>$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);