re = /(?<=>)[0-9A-za-z]*(?=<\/a>)/m
str = '<div class="termWrap "><a class="color1" href="/terms/?q=colors" target="_blank">09120000000</a><sup title="Frequency in the text">474</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=designers" target="_blank">09120000000</a><sup title="Frequency in the text">67</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=pantone" target="_blank">09120000000</a><sup title="Frequency in the text">53</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hue" target="_blank">09120000000</a><sup title="Frequency in the text">44</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=palette" target="_blank">09120000000</a><sup title="Frequency in the text">43</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=printing" target="_blank">09120000000</a><sup title="Frequency in the text">39</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hues" target="_blank">09120000000</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end