#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^\d{4}-\d{3}?)(.*)"
Local $sString = "#Valid:" & @CRLF & _
"1234-567 ABCD efgh" & @CRLF & _
"1600-141 Lisboa" & @CRLF & _
"" & @CRLF & _
"#Invalid:" & @CRLF & _
"1234567" & @CRLF & _
"1234 567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")