using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\d{4}-\d{3}?)(.*)";
string input = @"#Valid:
1234-567 ABCD efgh
1600-141 Lisboa
#Invalid:
1234567
1234 567";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}