#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$"
Local $sString = "介绍一下#" & @CRLF & _
"给我说说#" & @CRLF & _
"给我介绍一下#吧" & @CRLF & _
"" & @CRLF & _
"说说#是什么" & @CRLF & _
"介绍一下#是啥" & @CRLF & _
"什么是#" & @CRLF & _
"#是啥啊" & @CRLF & _
"" & @CRLF & _
"|#的?(简介|介绍)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")