Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$
/
gm
Input 1
1
New
介绍一下# 给我说说# 给我介绍一下#吧 说说#是什么 介绍一下#是啥 什么是# #是啥啊 |#的?(简介|介绍)