const regex = /8[^\d]*+8[^\d]*+8[^\d]*+9[^\d]*+5[^\d]*+9[^\d]*+2(?:[^\d]|0)*+1[^\d]*+1/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('8[^\\d]*+8[^\\d]*+8[^\\d]*+9[^\\d]*+5[^\\d]*+9[^\\d]*+2(?:[^\\d]|0)*+1[^\\d]*+1', 'gmi')
const str = `-888x(959)x2O11
88 8~(959) <2O><11>
8889592011
8;?889592011
888 ^9 <5> 9 2 <O>11
8abc8[8];',. 9 **5 92011
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}