# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(\w{1,3})(?:-\1)*-(\w+)(?!\S)/\1/gm;t' <<< "c-c-c-c-come oh-oh-oh-oh it's a bad life oh-oh-oh-oh
oh-oh-oh-oh
oh-oh
a-b-c
c-c-c-c-come to home today c-c-c-c-come to me test-test-test-a"