use strict;
my $str = 'c-c-c-c-come oh-oh-oh-oh it\'s a bad life oh-oh-oh-oh
oh-oh-oh-oh
oh-oh
a-b-c
c-c-c-c-come to home today c-c-c-c-come to me test-test-test-a';
my $regex = qr/(?<!\S)(\w{1,3})(?:-\1)*-(\w+)(?!\S)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";