import re
regex = re.compile(r"(?<!\S)(\w{1,3})(?:-\1)*-(\w+)(?!\S)", flags=re.MULTILINE)
test_str = ("c-c-c-c-come oh-oh-oh-oh it's a bad life oh-oh-oh-oh\n"
"oh-oh-oh-oh\n"
"oh-oh\n\n"
"a-b-c\n\n\n"
"c-c-c-c-come to home today c-c-c-c-come to me test-test-test-a")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)