Group protocol(?P<protocol>\w+) \w+any word character, repeated at least once
\s*any whitespace character, repeated any number of times
requestthe literal text request (case sensitive) \s*any whitespace character, repeated any number of times
fromthe literal text from (case sensitive) \s*any whitespace character, repeated any number of times
Group source_address(?P<source_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}) \d{1,3}a digit, repeated between 1 and 3 times
.any character (except for line terminators)
\d{1,3}a digit, repeated between 1 and 3 times
.any character (except for line terminators)
\d{1,3}a digit, repeated between 1 and 3 times
.any character (except for line terminators)
\d{1,3}a digit, repeated between 1 and 3 times
:the literal : (5810 / 728 / 3A16)
Group source_port(?P<source_port>\d+) \d+a digit, repeated at least once
\s*any whitespace character, repeated any number of times
tothe literal text to (case sensitive) \s*any whitespace character, repeated any number of times
Group destination_address(?P<destination_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}) \d{1,3}a digit, repeated between 1 and 3 times
.any character (except for line terminators)
\d{1,3}a digit, repeated between 1 and 3 times
.any character (except for line terminators)
\d{1,3}a digit, repeated between 1 and 3 times
.any character (except for line terminators)
\d{1,3}a digit, repeated between 1 and 3 times
:the literal : (5810 / 728 / 3A16)
Group destination_port(?P<destination_port>\d+) \d+a digit, repeated at least once
.any character (except for line terminators)
\s*any whitespace character, repeated any number of times
Action:the literal text Action: (case sensitive) \s*any whitespace character, repeated any number of times
Group action(?P<action>\w+) \w+any word character, repeated at least once
.any character (except for line terminators)
\s*any whitespace character, repeated any number of times
Rulethe literal text Rule (case sensitive) \s*any whitespace character, repeated any number of times
Collection:the literal text Collection: (case sensitive) \s*any whitespace character, repeated any number of times
Group rule_collection(?P<rule_collection>[^\s.]+) Negated Character Class[^\s.]+ +matches at least one character outside the set below:
\sany whitespace character
.the literal . (4610 / 568 / 2E16)
.any character (except for line terminators)
\s*any whitespace character, repeated any number of times
Rule:the literal text Rule: (case sensitive) \s*any whitespace character, repeated any number of times
Group rule(?P<rule>[^\s}]+) Negated Character Class[^\s}]+ +matches at least one character outside the set below:
\sany whitespace character
}the literal } (12510 / 1758 / 7D16)
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string