using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*1\*(.*?)\*11\*(.*?)\*(?:(?!IGNORE).)*?\*53\*(.*?)##";
string input = @"*1*20*11*30*IGNORE*53*40##
*1*20*11*30*some*53*40##";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}