const regex = /([0-9][0-9][0-9]:([0-1][0-9]|[2][0-3]):([0][1-9]|[1-5][0-9]))|([0-9][0-9][0-9]:([0][1-9]|([1][0-9])|[2][0-4]):[0-5][0-9])|(([0-9][0-9][1-9]|[0-9][1-9][0-9]|[1-9][0-9][0-9]):([0-1][0-9]|[2][0-4]):[0-5][0-9])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9][0-9][0-9]:([0-1][0-9]|[2][0-3]):([0][1-9]|[1-5][0-9]))|([0-9][0-9][0-9]:([0][1-9]|([1][0-9])|[2][0-4]):[0-5][0-9])|(([0-9][0-9][1-9]|[0-9][1-9][0-9]|[1-9][0-9][0-9]):([0-1][0-9]|[2][0-4]):[0-5][0-9])', '')
const str = `001:00:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}