$re = '/,(?!\d)/m';
$str = 'aaa,bbb,$33,222,ccc,$22,000';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;