package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\\(begin|end))\s*\{(.*?)\}`)
var str = `\begin{document}
\end{document}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}