// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"%(ASA|PIX|FWSM)-\w+-\d+-(\d+):.*").unwrap();
let string = "Jun 29 00:01:07 29 00: <177>:Jun 29 00:01:25 CEDT: %ASA-session-1-106021: Deny TCP reverse path check from 195.77.230.17 to 95.63.122.200 on interface dmz-Barcelone
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}