const regex = /(\d{5}\s?\d{5})?\s?(parcel\s?locker)\s?(\d{5}\s?\d{5})?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{5}\\s?\\d{5})?\\s?(parcel\\s?locker)\\s?(\\d{5}\\s?\\d{5})?', 'gi')
const str = `Parcel Locker 10080 88673
parcel locker 10080 88673
Parcel Locker 1008088673
parcel locker 1008088673
ParcelLocker1008088673
parcellocker1008088673
parcel locker1008088673
parcel locker 1008088673
parcel locker 10080 88673
10080 88673 Parcel Locker
10080 88673 parcel locker
1008088673ParcelLocker
1008088673parcellocker
hejsan parcel locker thug
Parcel street 1234567890
1234567890 Parcel street
Locker srteet 1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}