# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{5}\s?\d{5})?\s?(parcel\s?locker)\s?(\d{5}\s?\d{5})?"
test_str = ("Parcel Locker 10080 88673\n"
"parcel locker 10080 88673\n\n"
"Parcel Locker 1008088673\n"
"parcel locker 1008088673\n\n"
"ParcelLocker1008088673\n"
"parcellocker1008088673\n"
"parcel locker1008088673\n"
"parcel locker 1008088673\n"
"parcel locker 10080 88673\n\n"
"10080 88673 Parcel Locker\n"
"10080 88673 parcel locker\n\n"
"1008088673ParcelLocker\n"
"1008088673parcellocker\n"
"hejsan parcel locker thug\n"
"Parcel street 1234567890\n"
"1234567890 Parcel street \n"
"Locker srteet 1234567890")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.