using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$([0-9]+)(\.[0-9]{1,2})?";
string substitution = @"$\1\2";
string input = @"$128.99
$140
$6.82
$4.5";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}