import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([0-9]+) x )*([^@\\v]+)(@ ([0-9]+\\.[0-9]+)\\/(.*))*$";
final String string = "3 x Private Full Cabinet 42U Setup Fee @ 500.00/each\n"
+ "3 x Private Full Cabinet 42U (02/13/2020 - 03/12/2020) @ 500.00/each\n"
+ "3 x Primary Circuit Setup Fee @ 300.00/each\n"
+ "3 x Primary Circuit (02/13/2020 - 03/12/2020)\n"
+ "Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 325.00/each\n"
+ "3 x Redundant Circuit Setup Fee @ 300.00/each\n"
+ "3 x Redundant Circuit (02/13/2020 - 03/12/2020)\n"
+ "Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 81.25/each\n"
+ "DIA (02/13/2020 - 03/12/2020)\n"
+ "Carrier Neutral Blend: 100Mbps Flat Rate\n"
+ "IPv4 Setup Fee\n"
+ "IPv4 (02/13/2020 - 03/12/2020) Network: /29";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}