const regex = /(\d+)(?!.*\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(?!.*\\d)', 'g')
const str = `<p style="font-family:Arial, Helvetica, sans-serif; font-size:18px;"> <strong> This is the information you need 5 times you can see.</strong></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}