import Foundation
let pattern = #"(\d+)(?!.*\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p style="font-family:Arial, Helvetica, sans-serif; font-size:18px;"> <strong> This is the information you need 5 times you can see.</strong></p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)