#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^;]|^)(\n)"
Local $sString = "A;1;" & @CRLF & _
"B;2" & @CRLF & _
"C;3"
Local $sSubst = "$1;$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)