package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^;]|^)(\n)`)
var str = `A;1;
B;2
C;3`
var substitution = "$1;$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}