const regex = /([^;]|^)(\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^;]|^)(\\n)', 'gm')
const str = `A;1;
B;2
C;3`;
const subst = `$1;$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);