use strict;
my $str = 'A;1;
B;2
C;3';
my $regex = qr/([^;]|^)(\n)/mp;
my $subst = '$1;$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";