$re = '/(?<!Test1\s)Test2(?!\sTest3)/m';
$str = '1. Test1 Test2 Test3
2. Test1 Test2 NotTest3
3. Test1Not Test2 Test3
4. Test2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);