import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!_(?!_))(?!(?:.*[^_\\n])?_$)[\\w.-]+$";
final String string = "Valid Entries: \n"
+ "abc\n"
+ "ABC\n"
+ "Abc123\n"
+ "123a\n"
+ "Abc_12\n"
+ "Abc_12_3a\n"
+ "abc_23_43_fg\n"
+ "___should_work_but_doesnt__________\n"
+ "___ok__\n"
+ "___ok____\n"
+ "__a__\n\n"
+ "Invalid Entries: \n"
+ "_abc\n"
+ "abc_\n"
+ "_abc_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}