const regex = /^http:\/\/mywebsite\/(index\.aspx\?db=[A-Z]+)?#((id%\w+(%3B)?)|(view%\w+(%3B)?)|(page%\w+(%3B)?))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http:\\\/\\\/mywebsite\\\/(index\\.aspx\\?db=[A-Z]+)?#((id%\\w+(%3B)?)|(view%\\w+(%3B)?)|(page%\\w+(%3B)?))*$', 'gm')
const str = `http://mywebsite/index.aspx?db=DAYTON#id%3D7304%3Bpage%3D1%3Bview%3Dpages
http://mywebsite/#id%3D3D7304%3Bpage%3D1%3Bview%3Dpages
http://mywebsite/#view%3D3D7304%3Bpage%3D1%3Bid%3Dpage
http://mywebsite/#page%3D3D7304%3Bid%3D1%3Bview%3Dpage`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}