$re = '/(?:a|b|c)*(?<!abc)/m';
$str = 'afdasfdabc
a
ab
ac
cab
abc
aabbcc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);