import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/url\\?q=|&.+)";
final String string = "/url?q=https://website.com/&sa=U&ved=2ahUKEwjNyNv9z7fdfdXHEFkFHUpsEK8QFnoECAUQAg&usg=Agggaw2opjkKEAUPzyKjTJnkzQyZ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}