use strict;
my $str = 'vinamra@gmail.com
vinm@fmmao.com
vin @ . com
vdd@us.com.com
sh sha @cc.com
vin@dnsldfnsdlfsnflsnslfnd.com
ddd@11.com
sdf@ff.com
as@com
john @gmail.com
Akasdfgnqwefujqfj^1234!1k@gmail.com
T1hisi4snot5anem6ail@mcd.com
John.Smith@mcd.com
Joe.Smith@cmd.com
test
@ .
john @bkla.com
';
my $regex = qr/^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}