package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<wrappers>(?:[[:alpha:]][[:alnum:]]+://)*)(?<root>(?:[[:alpha:]]:/|/)?)(?<path>(?:[[:print:]]*))$`)
var str = `vfs://D:/really/long/path/0.0.1/.././.secret/hide/out.sh`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}